EduSecTM Application Requirement Checker


Description

This script checks if your server configuration meets the requirements for running Yii/EduSec application. It checks if the server is running the right version of PHP, if appropriate PHP extensions have been loaded, and if php.ini file settings are correct.

There are two kinds of requirements being checked. Mandatory requirements are those that have to be met to allow Yii to work as expected. There are also some optional requirements being checked which will show you a warning when they do not meet. You can use Yii framework without them but some specific functionality may be not available in this case.

Conclusion

Congratulations! Your server configuration satisfies all requirements.

Details

NameResultRequired ByMemo/Details
Assets Directory Permission Passed Yii Framework Assets directory must be writable by the Web server process.
/home/bookmella/public_html/fee-system/assets
Runtime Directory Permission Passed Yii Framework Runtime directory must be writable by the Web server process.
/home/bookmella/public_html/fee-system/runtime
Data Directory Permission Passed EduSec Data directory must be writable by the Web server process.
/home/bookmella/public_html/fee-system/data
Config Directory Permission Passed EduSec Config directory must be writable by the Web server process.
/home/bookmella/public_html/fee-system/config
PHP version Passed EduSec/Yii Framework PHP 5.4.0 or higher is required.
Current PHP version : 7.2.34
PDO extension Passed All DB-related classes
PDO MySQL extension Passed All DB-related classes Required for MySQL database.
Reflection extension Passed Yii Framework
PCRE extension Passed Yii Framework
SPL extension Passed Yii Framework
MBString extension Passed Multibyte string processing Required for multibyte encoding string processing.